close

Necessary update of your password on PrestaShop Addons

Hello,

You are currently the holder of an Addons account created from your Paypal account, which allows you to connect to our marketplace.

In order to increase security and simplicity, we are implementing a single authentication system. Therefore, signing in with PayPal won’t be possible on our marketplace, from April 2nd on. Read morearrow_right_alt

To continue to access your personal space on PrestaShop Addons, we simply invite you to reset your password as of now by clicking on the link below.

You will receive a new password allowing you to directly sign in to your Addons account, without using PayPal. Once logged in, you will be able to change this password in your personal space.

Your Addons account will not be affected in any way by this development.

close

check_circle Il prodotto è stato aggiunto al carrello !

close
Your data will be transferred to the Partner when you download this module.
close

Confermo le mie informazioni personali per continuare

close

Ottimo, il tuo negozio adorerà! Hai appena scaricato questo modulo. Ora devi solo installarlo nel tuo negozio PrestaShop. Hai bisogno di un aiuto? Segui il nostro tutorial: Installare un modulo a pagamento o gratuito

V1.6.0.4 - V1.7.7.6
Dalla V1.6.0.4 alla V1.7.7.6

Panoramica

Soluzione di sicurezza per il tuo negozio online. Scansiona ed elimina vulnerabilità come PHPUnit e XsamXadoo e il malware, utilizzando compiti automatizzati. Aggiungi un firewall ai tuoi moduli per prevenire lo spam con Honeypot e Google reCAPTCHA.

Ciò che questo prodotto ti offre

event_available Migliora la sicurezza del tuo sito
Modulo di sicurezza per il tuo negozio online.

Rimuove le vulnerabilità PHPUnit e XsamXadoo e altri malware dal tuo negozio.

Il modulo controlla tutte le cartelle e i file nel tuo negozio online e rileva i file e le cartelle PHPUnit e XsamXadoo e, se configurato, li rimuove completamente dal tuo negozio con un solo clic del mouse.Non è necessario accedere via FTP per trovare i file e le cartelle affetti da queste vulnerabilità, il modulo lo fa automaticamente per te.

Queste vulnerabilità sono considerate gravi. Se questa vulnerabilità non viene testata e rimossa, gli hacker saranno in grado di accedere al tuo server, visualizzare e/o cancellare i dati dal tuo negozio. Un negozio senza patch può permettere a un hacker di avere il pieno controllo del tuo negozio, compreso l'accesso alla scrittura dei file e l'accesso al database.

Il modulo controlla tutti i file del tuo negozio per rilevare i file modificati. Controlla anche se ci sono cartelle o file con permessi di scrittura modificati dal malware e ti permette di ricostruirli.

Oltre a mantenere i file di codice del tuo negozio protetti, include anche un potente firewall per i moduli standard del tuo negozio online. Impedisce a qualsiasi bot di inviarti spam attraverso i moduli del tuo negozio. Non sarebbe la prima volta che un negozio smette di vendere a causa di attacchi di spam sui suoi moduli, per aver lasciato il negozio bloccato dall'invio di email che lasciano l'email del negozio inutilizzabile.

Hai due opzioni diverse da configurare, il famoso reCAPTCHA di Google e il sistema di sicurezza Honeypot. Con Honeypot avrai una sicurezza extra nei moduli senza la necessità di aggiungere un captcha, ma se vuoi avere una sicurezza extra, puoi mettere entrambi i sistemi a lavorare allo stesso tempo, sarà molto difficile per un bot inviare spam nei tuoi moduli. E con l'uso di reCAPTCHA v3, non sarà una seccatura per i tuoi clienti.

Ciò che i tuoi clienti apprezzeranno

I tuoi clienti saranno protetti da qualsiasi malware o vulnerabilità nel tuo negozio, avranno la certezza di fare acquisti in un negozio sicuro che fa tutto il possibile per mantenere i loro dati al sicuro.

Installazione

Uso in multi-store
Il modulo supporta la modalità multi-store. Puoi avere il modulo installato in tutti i negozi del tuo multi-store e utilizzare configurazioni diverse in ognuno di essi o configurarlo solo una volta per ogni negozio del multi-store. Ma ricorda che se vuoi usarlo per diverse installazioni di PrestaShop o Thirty Bees (negozi indipendenti), devi comprare una licenza di modulo per ciascuna di queste installazioni.

Altro

Le nostre garanzie
Il team di sviluppatori certificati di IDX ti aiuterà con tutto ciò di cui hai bisogno. Faremo del nostro meglio per risolvere il tuo problema nel più breve tempo possibile. Grazie alla nostra alta qualifica di agenzia certificata PrestaShop, saremo in grado di offrirti soluzioni veloci e di qualità. Ti assicuriamo che sarete soddisfatti dei nostri prodotti e del nostro supporto.

Ti offriamo il miglior supporto. Se hai qualche problema con uno dei nostri moduli Prestashop, puoi contattarci in modo che possiamo aiutarti a risolverlo.

  • Hai problemi con il modulo? Se il modulo ti dice che un override è già stato modificato da un altro modulo, contattaci e ti diremo come combinare le due modifiche in modo che entrambi i moduli funzionino correttamente.
  • e hai dubbi durante l'installazione o la configurazione del modulo, contattaci e uno dei nostri tecnici ti spiegherà come fare.
  • Aggiornamenti costanti: I nostri moduli sono sempre aggiornati per garantire un funzionamento ottimale con tutte le versioni di PrestaShop e Thirty Bees.
  • Se hai problemi e ci chiedi aiuto, avremo bisogno di accedere al tuo negozio tramite FTP e accesso come amministratore. Se non ci dai accesso, non potremo aiutarti.
  • Rimborsiamo i moduli solo se soddisfano i requisiti stabiliti da PrestaShop nelle loro condizioni di vendita e se il modulo ha un problema che non possiamo risolvere. Se non intendi permetterci l'accesso per verificare il problema, non richieda un rimborso perché non lo riceverà.

Tutti i moduli che sviluppiamo sono testati con PrestaShop 1.6 e 1.7, così come con Thirty Bees (evoluzione di Prestashop 1.6). Sono testati con i templates ufficiali di ogni versione. È possibile che se il tuo template non è uno di quelli ufficiali, potresti dover fare qualche aggiustamento estetico al modulo.Non è incluso nel prezzo del modulo, il fatto che IDX debba fare tali modifiche. Puoi richiederlo come un lavoro aggiuntivo che verrà preventivato.

Compatibilità con moduli di terze parti e sviluppi personalizzati
I nostri moduli sono garantiti per funzionare con i moduli ufficiali PrestaShop e Thirty Bees inclusi di default in tutti i negozi e con i nostri moduli. Non sono garantiti per funzionare con moduli di terze parti, ce ne sono migliaia disponibili e sarebbe impossibile. È possibile richiedere un preventivo per la compatibilità con altri moduli. Quando abbiamo molte richieste di compatibilità con un particolare modulo, lo facciamo direttamente e rilasciamo un aggiornamento.
Se hai bisogno di funzionalità aggiuntive per il modulo, puoi anche richiedere un preventivo.
Dovrai tenere conto che non sempre abbiamo disponibilità, le nostre scadenze per fare questo tipo di lavoro di sviluppo personalizzato, possono essere diversi mesi.

Hai bisogno di aiuto?

Il nostro team risponde nelle seguenti lingue:
es, en

Scheda tecnica

Ultimo aggiornamento

10/06/2021

Lingue del modulo

en, ag, br, de, es, fr, gb, it, mx, nl, pl, pt, ru, ve +8

Versioni compatibili con PrestaShop

V1.6.0.4 - V1.7.7.6

Compatibilità multi-negozio 

info

Versione modulo

V 1.3.2

Numero di download

65

Documentazione

Included

Sviluppatore

InnovaDeluxe

Lingue di supporto

es, en

Categoria

Strumenti per l’amministrazione

Caratteristiche

Opzioni configurabili
  • Scansioni automatiche:  Fa due diversi tipi di scansioni quando entra nella configurazione del modulo 1. File core modificati. 2. Moduli vulnerabili. Se ci fosse qualche file modificato lo mostrerebbe.
  • PHPUnit: Permette di attivare la revisione della vulnerabilità di PHPUnit e di indicare se eliminare le cartelle localizzate di questa vulnerabilità. Se si attivano queste opzioni e si configura anche un CRON job per rivedere periodicamente il tuo negozio, l'avrai sempre protetto.
  • XsamXadoo_bot: È possibile abilitare la scansione e la rimozione dei file di XsamXadoo_bot. Questo malware è utilizzato per ottenere l'accesso al tuo negozio online, prendere il controllo e rubare i dati dei tuoi clienti o anche apportare modifiche ai file per effettuare l'invio di e-mail di massa dal tuo server o inviare traffico ad altri siti web. Abilitando le impostazioni possiamo prevenire e risolvere rapidamente questa vulnerabilità.
  • Scansione di malware: È possibile abilitare la scansione dei malware, così avrai il tuo negozio al sicuro. Abilitando la scansione dei malware ed eseguendo la sua analisi, si hanno molti vantaggi, tra cui la possibilità di rimuovere i malware con un solo clic.
  • Cron jobs: Ti permette di aggiungere dei cron jobs al tuo server, in tal modo si  eseguiranno automaticamente delle scansioni periodiche di sicurezza per controllare che il tuo negozio sia privo di malware e continui a funzionare correttamente.
  • Email: È possibile configurare un account di posta elettronica a cui verranno inviate le notifiche dei risultati della scansione dei malware. Se non viene specificato alcun indirizzo e-mail, verrà utilizzata la mail principale del negozio online. 

Tipi di analisi
  • Analisi di PHPUnit
  • Analisi de XsamXadoo
  • Analisi di Malware
  • Analisi dei file modificati
  • Analisi dei file CORE modificati
  • Analisi dei permessi di scrittura modificati

File system 
  • Cartella da scansionare: Il modulo scansiona completamente la cartella principale dove è installato il negozio. 
  • Scansione dei file e dei permessi modificati:  Con un solo clic sarete in grado di avviare la scansione dei file nel negozio. In poco tempo il modulo ti mostrerà i risultati ottenuti. Hai tre diversi tipi di scansioni. Puoi controllare se i permessi di scrittura dei file PHP sono stati alterati e impostati a 777. Puoi anche fare una scansione per vedere se qualche file del negozio e specialmente il Core di prestashop, sono stati modificati.
  • Registro di scansione dei file: Avrai un registro di tutte le scansioni che hai eseguito. Puoi controllare il risultato in qualsiasi momento. 
  • File modificati: Quando si esegue la scansione dei file modificati, restituisce una lista dei file che sono stati modificati dall'ultima scansione eseguita.
  • File modificati core: Quando si esegue la scansione dei file modificati del CORE di PrestaShop, restituisce un elenco di file che sono stati modificati indipendentemente dalle scansioni precedenti.
  • Permessi 777: Per far funzionare correttamente il tuo negozio, i permessi delle cartelle dovrebbero essere 755 e dei file 644. Puoi controllare che i permessi siano corretti e nel caso in cui rilevi un file o una cartella errata, correggila. Evitare i permessi errati vi terrà protetti dalle vulnerabilità.
  • Compiti Cron: Puoi creare dei compiti CRON automatizzati sul tuo server per eseguire scansioni periodiche del tuo negozio in modo automatizzato. Sarai in grado di rivedere il risultato di ogni scansione ogni volta che ne hai bisogno.

Firewall
  • Sicurezza nei moduli: Puoi abilitare le impostazioni di sicurezza per i moduli del tuo negozio. Si attiva un Honeypot che impedisce ai bot di inviarti spam.
  • reCAPTCHA v3: Puoi abilitare Google reCAPTCHA v3 per aggiungere ulteriore sicurezza ai tuoi moduli.
  • Moduli: Puoi attivare i moduli "Accedi", "Registrati", "Contatto" e "Newsletter".

Raccomandazione

Si consiglia di utilizzare un compito CRON automatizzato, fare revisioni periodiche del negozio, sia per malware, vulnerabilità che per la revisione dei permessi di scrittura. In questo modo manterrai il tuo negozio in salvo dal furto di dati.
Si raccomanda anche di utilizzare un firewall combinato con reCAPTCHA e Honeypot.

Novità nella versione 1.3.2(10/06/2021)

  • Revisión permisos scanner malware
  • Compatibilidad con Thirty Bees

Supporto e aggiornamenti

Garantisci il buon funzionamento di questo prodotto sul tuo negozio per 12 mesi con l’Opzione Zen!

Grazie all’Opzione Zen, hai accesso a TUTTI gli aggiornamenti del prodotto per un anno dopo l'acquisto. Lo sviluppatore del prodotto ti accompagna rispondendo per e-mail a tutte le tue domande tecniche e funzionali.

Che cos'è l'Opzione Zen?

L'opzione Zen comprende due servizi:

  • un supporto post-vendita illimitato durante il periodo coperto dall'opzione;
  • l’accesso a tutti gli aggiornamenti di questo prodotto durante questo periodo.

L'Opzione Zen è disponibile a un prezzo vantaggioso al momento dell'acquisto di questo prodotto e, in caso di ripensamenti, puoi ottenerla anche dopo l'acquisto a partire dal tuo account. rnÈ valida per un anno a partire dalla data di acquisto del prodotto. Prima l'acquisti, più a lungo ne approfitti!

Cosa include l'opzione Zen?

L'Opzione Zen comprende:

  • le domande relative all'utilizzo del modulo/tema;
  • la risoluzione di eventuali problemi tecnici legati al modulo/tema;
  • accesso a tutti gli aggiornamenti del modulo/tema.

L'Opzione Zen non comprende le seguenti prestazioni:

  • la personalizzazione e lo sviluppo specifico;
  • le prestazioni di installazione e di aggiornamento del modulo/tema;
  • la risoluzione di problemi relativi a servizi esterni, l'hosting, il server o, ancora, il software PrestaShop.

Hai bisogno di aiuto?

Il nostro team risponde nelle seguenti lingue:
es, en

Informazioni sullo sviluppatore

Livello di competenze

Superhero

Prodotti in elenco

47

Sviluppatore dal

23/05/2011

Paese

Spain

Lingue di supporto

es, en

InnovaDeluxe

Creiamo design su misura e personalizzazioni esclusive, siamo specializzati nell’integrazione di PrestaShop con altri strumenti: Sistemi di fatturazione, Sistemi POS, ERP. Abbiamo sviluppato diverse centinaia di moduli su misura. Non esitare, consultati con noi. Siamo in grado di realizzare ogni tipo di sviluppo di cui tu possa avere bisogno.

 

Riuniamo tutte le competenze necessarie per la progettazione, l’esecuzione e il monitoraggio di qualsiasi progetto e-commerce. Ci facciamo carico di un progetto e diventiamo un fornitore globale di servizi, dando il miglior supporto ai nostri clienti, facendo in modo che il cliente possa dimenticarsi di ogni cosa e si occupi solo di ciò che è importante: vendere.